关于PHP安装pthreads扩模的问题:是不是PHP7.2装pthreads不需要开启Thread Safety

PHP的pthreads扩模官方文档介绍说:(原文地址 http://php.net/manual/en/intro.pthreads.php)
只能在 PHP 7.2+ 版本中使用 pthreads (v3) 扩展, 在 PHP 7.0 和 7.1 版本中,ZTS 模式是不安全的
英文:pthreads (v3) can only be used with PHP 7.2+: This is due to ZTS mode being unsafe in 7.0 and 7.1.

怎么理解这句话,下面两种哪种理解正确
1、只能在PHP7.2并同时开启Thread Safety才能装pthreads,在php7.0和7.1无论如何都不行
2、PHP7.2开不开Thread Safety都行,但7.0和7.1必须开启Thread Safety才能装

或者上面两种理解都不正确?
希望有人指导一下,打算改造服务器

评论 (0)链接2018-08-14 
德问是一个专业的编程问答社区,请 登录注册 后再提交答案